Support
Notifications
Clear all

[Solved] Front End Editor Gone


Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

Hi there, 

I downloaded the free version last night and loved it so within 30 minutes bought the pro unlimited 3 year package however...

Now I'm using the pro version though, I can't see the front end editor anymore.  See loom video.  Is it anywhere else?

https://www.loom.com/share/4e7862f4cbba43848a892b4415a9b9f1


Quote
Deep Presentation
(@admin)
Member Admin
Joined: 2 years ago
Posts: 77
 

Hi there,

Sorry to hear that visual builder is not loading. Does it happen in general at all pages, or just at member-dashboard?

Can you try to turn off Allow Just for Logged in Users and First User Visit Only. That could guide me to the place of bug.

If these doesn't make effect, could you provide a temporarily access to admin board, so I can investigate it? You can start a new Private thread to pass on the credentials.

If it is not possible, can you please turn on  Debug Console Output in global plugin options and send me a print-screen of debug console on member-dashboard after you click CONFIGURE STEPS VISUALLY (right click and inspect in chrome win ->console tab)

 


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

@admin Hi Tomas,

Thanks for getting back to me.  It seems to work on other pages, just not on my member dashboard, although it worked on my member dashboard in the free version.  I disabled "Allow Just for Logged in Users" as well as "First User Visit Only" and still can't get it to work on the member dashboard, I'm afraid.  I have sent an email to you with your login details but please do let me know if you don't get it or have any issues.

Many thanks for your support with this.


ReplyQuote
Deep Presentation
(@admin)
Member Admin
Joined: 2 years ago
Posts: 77
 

Hi there,

Thanks for sending me login details. However I can't see intro tours configuration, so I can't try to run a visual builder. I would need higher user role, that has edit post rights at least.


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

@admin Apologies.  You should have admin access now 🙂


ReplyQuote
Deep Presentation
(@admin)
Member Admin
Joined: 2 years ago
Posts: 77
 

Fatal error: Uncaught Error: Call to undefined function wp_generate_attachment_metadata()
in /home/customer/www/linguamasteri.com/public_html/wp-content/plugins/buddyboss-platform/bp-core/bp-core-functions.php on line 5498

This is what is happening and it is in buddyboss-platform plugin. That stops all other php processing.

I installed query monitor plugin that can show you that. It is happening only when builder mode is activated. I have inkling, what part can cause it, but don't want to overwhelm you with technical details.

I recommend to contact buddyboss-platform support and report this error. I'm open to assist if they need cooperate as this seems like plugin interaction issue. You can give them my contact mail.

Also you can forward them following details with code, where I think interaction can happen:

For intro tour frontend builder, there is used wplink core feature and for that it is loaded hidden editor:

wp_enqueue_scripts hook:

Dp_Intro_Tours_Helper::enqueue_dpwplink_script('dpwplink'); // adjusted wplink
wp_enqueue_style( 'editor-buttons' );
wp_enqueue_script('wpdialogs');
wp_enqueue_script('wpdialogs-popup');
wp_enqueue_style('wp-jquery-ui-dialog');
wp_enqueue_style('thickbox');
wp_editor('', 'dpwplink-editor-public', array('editor_class'=>'hidden'));
 
wp_footer hook:
 
require_once ABSPATH . "wp-includes/class-wp-editor.php";
//require_once ABSPATH . "wp-admin/load-styles.php";
_WP_Editors::wp_link_dialog(); 


?>
<script type="text/javascript">
/* We need ajaxurl to send ajax to retrive links */
var ajaxurl = "<?php echo admin_url( 'admin-ajax.php'); ?>";
//var wpActiveEditor = 'acf_content';
</script><?php

 


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

@admin Thank you so much.  I'll get in contact with them and see what can be done to sort it out.  I'll keep you updated if they don't.

Very much appreciated.


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

OK, so I found a conflict with a plugin and have deactivated it.  I can live without it.  Now I only have one PHP error "Version warning: Imagick was compiled against Image Magick version 1690 but version 1691 is loaded. Imagick will run but may behave surprisingly" but am still experienceingf the same issue.  I'm not sure what this error relates to so not sure if it's Buddyboss , the intro tour or something else?


ReplyQuote
Deep Presentation
(@admin)
Member Admin
Joined: 2 years ago
Posts: 77
 

That warning is not from intro tours, anyway warning is fain, it doesn't stop php processing. But when I try to run builder at member-dashboard page, there is still fatal error, that I mentioned in previous message, so I don't think it is fixed.


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

@admin Ok thank you.  They are still working on this but it may well take some time.  I'll get back to you when / if I get any further forward with the issue.

Thanks again

Helen


ReplyQuote
Deep Presentation
(@admin)
Member Admin
Joined: 2 years ago
Posts: 77
 

@helen-linguamasteri You are very welcome.

 


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

Hi, I have a response from Buddyboss:

Base on the Fatal Error, Intro Tours plugin is not compatible with BuddyBoss platform. Intro Tours did not loads all required functions for buddyboss to work properly.

I see this on your wordpress dashboard( ) this maybe the cause of Intro Tours fails to load required function for the buddyboss.

Base on my knowledge on the error "Uncaught Error: Call to undefined function wp_generate_attachment_metadata", this function wp_generate_attachment_metadata is a wordpress default function, why it is not available when you are in the state of editing the Intro Tours.

Hope this information helps the plugin developers.


ReplyQuote
Deep Presentation
(@admin)
Member Admin
Joined: 2 years ago
Posts: 77
 

Hi @helen-linguamasteri,

I adjusted a part in our plugin, that made an issue and uploaded new beta version to your site.

It seems it works now:) 

Have a nice day

Tomas

 


ReplyQuote
Linguamasteri
(@helen-linguamasteri)
Active Member Customer
Joined: 1 year ago
Posts: 12
Topic starter  

@admin Thank you so so much. The front end editor is working really well now.  Can't wait to set this up and help with my clients on-boarding.  😀


ReplyQuote
Share:
chevron-right-circle linkedin facebook pinterest youtube rss twitter instagram facebook-blank rss-blank linkedin-blank pinterest youtube twitter instagram